You are browsing the archive for Subversion.

Avatar of admin

by admin

Re: Error Validating Certificate

March 5, 2009 in Subversion

Yes it is true we build and bundle our own OpenSSL library. I’ve opened a
ticket internally to bundle a default trusted certificates list with out
package.

Mark

On 3/5/09 12:40 PM, “Raj Singh” wrote:

> bench@host30:/shares/perf/bench/examinator/trunk> /usr/local/bin/svn up
> Error validating server certificate for ‘https://svn.terracotta.org:443′:
> – The certificate is not issued by a trusted authority. Use the
> fingerprint to validate the certificate manually!
> Certificate information:
> – Hostname: svn.terracotta.org
> – Valid: from Fri, 01 Dec 2006 23:06:57 GMT until Tue, 01 Dec 2009 23:06:57
> GMT
> – Issuer: Equifax Secure Certificate Authority, Equifax, US
> – Fingerprint: 32:14:3f:9f:ac:de:b1:a9:c7:1f:89:a3:7f:73:a4:25:a6:a4:3c:84
> (R)eject or accept (t)emporarily? t
> Authentication realm: Terracotta Realm
> Password for ‘bench':
> Authentication realm: Terracotta Realm
> Username: bench
> Password for ‘bench':
> Authentication realm: Terracotta Realm
> Username:
>
>
> Actually, this is a question about SSL libraries. Collabnet subversion looks
> like it links against its own SSL libraries and not those of the system.
>
> $ ldd /usr/local/bin/svn | egrep “ssl|crypto”
> libssl.so.0.9.8 => //opt/CollabNet_Subv​ersion/lib/libssl.so​.0.9.8
> (0x00002b9dd1332000)
> libcrypto.so.0.9.8 =>
> //opt/CollabNet_Subv​ersion/lib/libcrypto​.so.0.9.8 (0x00002b9dd1479000)
>
> My binaries that are linked against the system OpenSSL libs have no trouble
> with the certificate authority (which is Equifax/Geotrust BTW, so it’s not
> like it’s even some self-signed CA)
>
> ——————————————————
> http://subversion.open.collab.net/ds/viewMessage.do?dsForumId=4&dsMessageId=30
> 3791

Avatar of admin

by admin

Subversion apache2 nis authentication

March 5, 2009 in Subversion

I have installed subversion 1.5.5-1 on CentOS 4.4.

I followed http://www.yolinux.com/TUTORIALS/LinuxTutorialApacheAddingLoginSiteProtection.html#NIS

I followed all the steps except I downloaded and installed “Apache2-AuthenNIS-0.15″ instead of “Apache-AuthenNIS-0.13″.

I added following in /etc/opt/CollabNet_Subversion/conf/httpd.conf.

# Code for nis authentication

AuthType Basic
AuthName “Enter your login ID:”
PerlAuthenHandler Apache2::AuthenNIS
PerlSetVar AllowAlternateAuth no
require valid-user

Now, svn configuration fails with the following error:

Stopping CollabNet Subversion: Syntax error on line 128 of /etc/opt/CollabNet_Subversion/conf/httpd.conf:
Invalid command ‘PerlAuthenHandler’, perhaps misspelled or defined by a module not included in the server configuration
Starting CollabNet Subversion: Syntax error on line 128 of /etc/opt/CollabNet_Subversion/conf/httpd.conf:
Invalid command ‘PerlAuthenHandler’, perhaps misspelled or defined by a module not included in the server configuration

When I try to install mod_perl2 (mod_perl-2.0.4):

cd mod_perl-2.0.4
perl Makefile.PL

Please provide a full path to ‘apxs’ executable
(press Enter if you don’t have it installed): /opt/CollabNet_Subversion/bin/apxs

[ error] Unable to open /opt/CollabNet_Subversion/include/ap_release.h: No such file or directory
[ error] Unable to determine server version, aborting.
[ error] Invalid MP_APXS specified?

I can not file /opt/CollabNet_Subversion/include directory in Collabnet’s installation.

Please help.